Browser Requirements for Online Banking

The basic Internet browser requirements are as follows, but not necessary depending on what you use. When viewing the website, if it  displays funny, please check that you have the plug-in below installed.  Also,  pop-up blockers may need to be turned off as www.becu.net also runs pop-up windows.

*  (IE8) Internet Explorer 8 or 9
*  Fire fox 19.0 or current up to date
*  Plug-in for both browsers:     Flash v10.0 or most current up to date,  Adobe Reader, or Java v6 or most current up to date